● Trunk 구성

switch(config)# feature lacp
switch(config-if)# interface ethernet 1/1-2
switch(config-if-range)# switchport mode trunk
switch(config-if-range)# channel-group 100

 

● Access 구성

switch(config)# feature lacp
switch(config-if)# interface ethernet 1/1-2
switch(config-if-range)# switchport access vlan 100
switch(config-if-range)# channel-group 100

 

● L3 구성

switch(config)# feature lacp
switch(config)# interface ethernet 1/1-2
switch(config-if-range)# channel-group 1 mode active
switch(config)# interface port-channel 1

switch(config-if)# no switchport --------------> routed(admin down)

switch(config-if)# ip address 10.1.1.1/24

or

switch(config)# interface eth1/1-2
switch(config-if-range)# no switchport --------------> access(up) >> routed(admin down)

switch(config-if-range)# channel-group 1 mode active

switch(config)# interface port-channel1
switch(config-if)# ip address 10.1.1.1/24

 

==========================================

 

** L3(routed mode) 설정된 port-channel에 물리 인터페이스(access mode)를 할당 하는 경우, 'port not compatible' Error 메시지 발생

   물리 인터페이스를 port-channel 인터페이스와 Mode를 맞춰야 함.

   no switchport 후 channel-group 설정 또는 channel-group 1 force mode active 적용.

    

switch(config)# int po9
switch(config-if)# no swi
switch(config-if)# ip add 1.1.12.1/30

switch(config)# int eth1/1-2
switch(config-if-range)# ch 9 mo ac
command failed: port not compatible [Ethernet Layer] 
** You can use force option to override the port's parameters 
** (e.g. "channel-group X force") 
** Use "show port-channel compatibility-parameters" to get more information on failure

 

※ L3(routed mode) 설정된 port-channel에 물리 인터페이스를 할당하는 2가지 방법

1. switch(config-if)# channel-group 9 force mode active (force 옵션 사용)

2. switch(config-if)# no switchport 후 channel-group 설정

 

==========================================

 

 * IOS

interface range gigabitEthernet 1/1-2
  channel-group 1 mode active

  no shutdown

interface Port-channel1
  no switchport
  ip address 1.1.12.2 255.255.255.252

 

● LACP 구성 확인

switch# show port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        b - BFD Session Wait
        S - Switched    R - Routed
        U - Up (port-channel)
        p - Up in delay-lacp mode (member)
        M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SD)     Eth      LACP      Eth1/1(D)
2     Po2(SU)     Eth      LACP      Eth1/2(P)
999   Po999(SD)   Eth      LACP      Eth1/5(s)    Eth1/6(s)

 

Port-channel(SD) : 현재 port-channel 상태가 Down 된 경우 / Eth1/1(D)는 해당 인터페이스 Down을 의미

Port-channel(SU) : 현재 port-channel 상태가 UP으로 Port-channel이 정상적으로 구성이 된 상태 / Eth1/2(P)는 해당 인터페이스 UP을 의미

Port-channel(SD) : 현재 port-channel 상태가 Donw 된 경우 / Eth1/5(s)는 대기중으로 대국의 장비 인터페이스 UP 상태이기는 하나 LACP

                               구성이 안되었을 경우 발생 

 

switch# show port-channel database interface port-channel 1
port-channel1
    Last membership update is successful
    2 ports in total, 2 ports up
    First operational port is Ethernet1/1
    Age of the port-channel is 0d:00h:38m:20s
    Time since last bundle is 0d:00h:35m:05s
    Last bundled member is Ethernet1/2
    Ports:   Ethernet1/1     [active ] [up] *
                 Ethernet1/2     [active ] [up]

 

switch# show lacp neighbor interface port-channel 1
Flags:  S - Device is sending Slow LACPDUs F - Device is sending Fast LACPDUs
            A - Device is in Active mode       P - Device is in Passive mode
port-channel1 neighbors
Partner's information
                 Partner                       Partner                               Partner
Port          System ID                   Port Number       Age         Flags
Eth1/1      32768,50-0-0-2-0-7     0x101                 2004        SA

                LACP Partner              Partner                               Partner
                Port Priority                 Oper Key                            Port State
                32768                          0x8000                               0x3d

Partner's information
                 Partner                       Partner                               Partner
Port          System ID                   Port Number       Age         Flags
Eth1/1      32768,50-0-0-2-0-7     0x102                 2004        FA

                LACP Partner              Partner                               Partner
                Port Priority                 Oper Key                            Port State
                32768                          0x8000                               0x3f

 

SW-1# show lacp counters interface port-channel 1
NOTE: Clear lacp counters to get accurate statistics
------------------------------------------------------------------------------
                             LACPDUs                      Markers/Resp LACPDUs
Port                        Sent                Recv                  Recv Sent  Pkts Err
------------------------------------------------------------------------------
port-channel1
Ethernet1/1             86                    73                     0      0    0      
Ethernet1/2             308                  81                     0      0    0 

 

SW-2show lacp counters interface port-channel 1
NOTE: Clear lacp counters to get accurate statistics
------------------------------------------------------------------------------
                             LACPDUs                      Markers/Resp LACPDUs
Port                        Sent                Recv                  Recv Sent  Pkts Err
------------------------------------------------------------------------------
port-channel1
Ethernet1/1             74                    76                     0      0    0      
Ethernet1/2             85                    297                     0      0    0 

 

switch# show vlan brief

 : interface를 port-channel에 할당하면 VLAN에서 해당 interface는 보이지 않음

 

 

 출처

https://blog.naver.com/91nomatter/222606525000

 

 

 

'네트워크 > LAG' 카테고리의 다른 글

LAG(LACP) - 개념  (0) 2023.04.29
[IOS-XR] NCS6008 LAG(Link Aggregation)  (0) 2023.03.21

개념 및 특징

여러 개의 물리적인 포트를 하나의 논리적인 포트로 만들어 사용하는 기술이다.

대역폭을 확장하여 병목 현상을 해결하고, 물리적인 포트를 다수 연결함으로써 발생하는 Loop 방지를 할 수 있다.

회선 다중화를 통해 하나의 링크가 Fail이 발생해도 나머지 링크를 통해 지속적인 서비스가 가능하며, Load-Balance 기능으로 효율적인 서비스가 가능함.

 

LACP(Link Aggregation Control Protocol)

802.3ad Standard 프로토콜로 LAG를 동적(Dynamic)으로 설정하기 위한 제어 프로토콜이다. 네트워크 스위치 간의 Link Aggregation 정보를 교환할 수 있다. LAG 정보는 LACPDU(Link Aggregation Control Protocol Data Units)에서 패킷으로 전달되며, LACP 동작 모드를 설정하여 LACPDU의 전송 방법을 정하고, 최대 16개의(8Backup) 포트를 지정할 수 있다.

 

 Temaing, Bonding -서버에서 인터페이스를 묶을 때 사용하는 용어
-windows 계열은 Teaming / Linux 계열은 Bonding
 Ether-Channel (Catylyst)
-네트워크에서 인터페이스를 묶을 때 사용하는 용어
-벤더에 따라서 용어를 조금씩 다르게 사용
 Port-Channel (NX-OS)
 Bundle-Ethernet (IOS-XR)
 Port-Truking

 

구성 조건

Speed, Duplex가 동일해야 한다.

Switch port mode가 동일해야 한다. (Access or Trunk)

Trunk portNative 또는 Allowed VLAN 정보가 동일해야 한다.

Access port에 대한 Access VLAN 구성이 동일해야 한다.

이더채널의 모든 포트는 SPAN(Switched Port Analyzer)이면 안 된다.

이더채널은 보안 설정이 되어 있는 Port는 구성 하지 않는다.

 

 구성 조건

Bandwidth 향상 : 여러 개의 물리적인 인터페이스를 하나의 논리적인 포트로 사용함으로써 대역폭을 늘릴 수 있다.

High Availability (고가용성) : 동일한 포트 그룹에 속한 링크 중 어느 하나가 단절 되더라도 나머지 링크를 통해서 지속적인 서비스가 가능하다.

 Load Balancing (부하분산)

 Loop 방지

 
※ 가용성(High Availability) 또는 부하분산(Load Balancing)을 위해 2개의 Link로 구성.
 

 

 

 가용성(high availability)과 부하분산(load balancing) 둘 다 가능하도록 2개의 link를 active-active 구성 및

- physical switch 2대를 logical switch 1대로 구성

   cisco : vPC

   juniper : VC

 

 

협상 방법

 [ LACP(802.3ad) Negotiation ]
 Active 내가 먼저 상대방에게 LACP message를 보내서 Channeling맺고자한다. (상대 portNegotiation을 주고받음)
 Passive 상대방이 나에게 LACP message를 보내면 그것에 대해 응답만 한다. (양쪽 모두 Passive이면 Ether-Channel이 구현되지 않는다.)
 On LACP로 동작하지 않는다. (채널링을 묶는데, 상대와 Negotiation을 하지 않는다)
 [ PAGP(cisco) Negotiation ]
 Auto 상대방이 나에게 PAGP message를 보내면 그것에 대해 응답만 한다. (양쪽 모두 Auto이면 Ether-Channel이 구현되지 않는다.)
 Desirable 내가 먼저 상대방에게 PAGP message를 보내서 Channeling 맺고자 한다. (상대 portNegotiation을 주고받음.)
 On PAGP로 동작하지 않는다. (채널링을 묶는데, 상대와 Negotiation을 하지 않는다)

 

◆ LACP Parameter

system-priority LACP가 동작하는 각 라우터에 자동 또는 수동으로 생성되며, Master/Slave를 정하여 Master 기준으로 LACP가 동작할 수있도록 한다.(0~65535(default 127), Low Value = High Priority)
system-id 장비들의 Actor(자신) MAC address 정보이다.
system-priorityMAC 값이 조합되어 고유한 LACP system-id가 생성된다.
administrative key LACP를 맺으려는 장비 간에 같은 key 값을 사용하는지 확인하여 채널링을 맺을 때 사용.
port-priority LACP 포트 구성원에 할당 된 인터페이스의 우선순위 설정.
0~65535(default 127) , Low Value = High Priority
port-id 인터페이스의 Index ID
액터 또는 파트너가 포트에 할당 한 포트 번호
flag LACP Activity : Passive = 0 / Active = 1
ACP Timeout : Long = 0 / Short = 1
Aggregation : Individual = 0 / Aggregatable = 1
Synchronization : Not in sync = 0 / in sync = 1
Collecting : Disable = 0 / Enable = 1
Distributed : No = 0, Yes = 1
Defaulted : No = 0, Yes = 1
Expired : No = 0, Yes = 1

'네트워크 > LAG' 카테고리의 다른 글

LAG - configuration  (0) 2023.04.29
[IOS-XR] NCS6008 LAG(Link Aggregation)  (0) 2023.03.21

- Bundle 내의 서로 다른 링크는 서로 다른 speed를 가질 수 있으며 가장 빠른 링크는 가장 느린 링크보다 최대 4배 빠를 수 있다.

- Bundle이 유지되는 데 필요한 minimum-active links 수는 2개 이다.

 

 

LAG Basic Configuration

 

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
interface Bundle-Ether 1
 ipv4 address 10.10.10.10/31
 ipv4 unreachables disable
 ipv6 address 1111:1111:1111:c:11:11:111:11/127
 ipv6 unreachables disable
 load-interval 30
!
interface Te0/1/0/1
 bundle id 1 mode active
 no shutdown
!
interface Te0/1/0/2
 bundle id 1 mode active
 no shutdown
!
interface Te0/2/0/1
 bundle id 1 mode active
 no shutdown
!
interface Te0/2/0/2
 bundle id 1 mode active
 no shutdown
 
cs

 

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
RP/0/RP0/CPU0:NCS-60087#show bundle bundle-ether 1
Thu Mar 16 02:30:59.178 KST
 
Bundle-Ether1
  Status:                                    Up
  Local links <active/standby/configured>:   4 / 0 / 4
  Local bandwidth <effective/available>:     40000000 (40000000) kbps
  MAC address (source):                      70ea.1aa8.fa03 (Chassis pool)
  Inter-chassis link:                        No
  Minimum active links / bandwidth:          1 / 1 kbps
  Maximum active links:                      64
  Wait while timer:                          2000 ms
  Load balancing:                            
    Link order signaling:                    Not configured
    Hash type:                               Default
    Locality threshold:                      None
  LACP:                                      Operational
    Flap suppression timer:                  Off
    Cisco extensions:                        Disabled
    Non-revertive:                           Disabled
  mLACP:                                     Not configured
  IPv4 BFD:                                  Not configured
  IPv6 BFD:                                  Not configured
 
  Port                  Device           State        Port ID         B/W, kbps
  --------------------  ---------------  -----------  --------------  ----------
  Te0/1/0/1            Local            Active       0x80000x0004    10000000
      Link is Active
  Te0/1/0/2            Local            Active       0x80000x0003    10000000
      Link is Active
  Te0/2/0/1            Local            Active       0x80000x0002    10000000
      Link is Active
  Te0/2/0/2            Local            Active       0x80000x0001    10000000
      Link is Active
cs

 

Minimum active links / bandwidth:          1(x) / 1(y) kbps
x - 번들이 작동하는 데 필요한 최소 활성 링크 수(1~번들에서 지원되는 최대 링크 수)입니다.
y - 번들이 작동하는 데 필요한 활성 링크의 최소 총 대역폭(kbps)입니다.
(파트너) - 피어 시스템의 값이 사용 중임을 나타냅니다.

 

Maximum active links:                      64

번들에서 활성화할 수 있는 최대 링크 수(1~번들에서 지원되는 최대값)

 

Wait while timer:
"protect" 또는 백업 링크를 Standby 상태로 이동하기 전에 시스템에서 LACP(Link Aggregation Control Protocol)가 "작동(working)" 링크를 협상하도록 허용하는 시간(miliseconds)입니다.

 

State

Active - Link는 트래픽을 보내고 받을 수 있습니다.
BFD Running - BFD가 다운되었거나 완전히 협상되지 않았기 때문에 링크가 비활성 상태입니다.
Configured - 구성 불일치로 인해 링크가 작동하지 않거나 다운된 상태로 유지됩니다. 활성 링크 장애 시 전환에 링크를 사용할 수 없습니다.
Hot Standby - 링크는 활성 링크에 장애가 발생하면 LACP PDU(프로토콜 데이터 장치)를 추가로 교환하지 않고 활성 상태로 즉시 전환할 수 있는 경우 인계할 준비가 되어 있습니다.
Negotiating(협상 중) - 링크가 LACP 협상 중이고 피어에 의해 더 낮은 LACP 상태로 유지되고 있습니다(예: 링크가 피어에서 대기 상태이기 때문에).
Standby - 링크가 트래픽을 보내거나 받고 있지 않지만 활성 링크 오류로 인한 전환에 사용할 수 있습니다.

 

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
RP/0/RP0/CPU0:NCS-6008#show interfaces bundle-ether 1
Thu Mar 16 02:31:08.539 KST
Bundle-Ether1 is up, line protocol is up 
  Interface state transitions: 1
  Hardware is Aggregated Ethernet interface(s), address is 70ea.1aa8.fa03
  Description: 
  Internet address is 10.10.10.10/31
  MTU 1514 bytes, BW 40000000 Kbit (Max: 40000000 Kbit)
     reliability 255/255, txload 0/255, rxload 0/255
  Encapsulation ARPA,
  Full-duplex, 40000Mb/s
  loopback not set,
  Last link flapped 00:00:24
  ARP type ARPA, ARP timeout 04:00:00
    No. of members in this bundle: 4
      TenGigE0/1/0/1              Full-duplex  10000Mb/s    Active          
      TenGigE0/1/0/2              Full-duplex  10000Mb/s    Active          
      TenGigE0/2/0/1              Full-duplex  10000Mb/s    Active          
      TenGigE0/2/0/2              Full-duplex  10000Mb/s    Active          
  Last input 00:00:16, output 00:00:00
  Last clearing of "show interface" counters never
  30 second input rate 2000 bits/sec, 2 packets/sec
  30 second output rate 1000 bits/sec, 2 packets/sec
     35 packets input, 4344 bytes, 0 total input drops
     0 drops for unrecognized upper-level protocol
     Received 1 broadcast packets, 34 multicast packets
              0 runts, 0 giants, 0 throttles, 0 parity
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     36 packets output, 4106 bytes, 0 total output drops
     Output 1 broadcast packets, 35 multicast packets
     1 output errors, 0 underruns, 0 applique, 0 resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
cs

 


 

options

RP/0/RSP0/CPU0:PE2(config-if)# mtu 9216

RP/0/RSP0/CPU0:PE2(config-if)# bundle maximum-active links 2 

RP/0/RSP0/CPU0:PE2(config-if)# bundle minimum-active links 2

   : active 링크가 2개 미만이면 bundle down 또는 Bundle이 활성화 되는데 필요한 활성화된 링크 수

   : 번들에서 허용되는 minimum-active links 수의 범위 1~8

   : 기준 대역폭을 보장해야 하는 경우 max, min link 설정

RP/0/RSP0/CPU0:PE2(config-if)# load interval 30  -------  부하 계산 간격

RP/0/RSP0/CPU0:PE2(config-if)# bundle ?

   maximum-active    활성화할 수 있는 링크 수에 대한 제한 설정

   minimum-active     번들이 활성화되기 위한 최소 기준을 설정합니다.

   shutdown               번들의 모든 링크를 대기 상태로 만듭니다.

   wait-while               이 번들의 구성원에 대한 대기 시간 제한을 설정합니다

 

RP/0/RSP0/CPU0:PE2(config-if)# bundle port-priority <1~65535>

   : 번들 멤버 링크 에 대한 포트 우선 순위를 구성(기본값 32768)

RP/0/RSP0/CPU0:PE2(config-if)# bundle load-balancing hash ?

   dst-ip      대상 IP를 해시 함수로 사용

   src-ip      소스 IP를 해시 함수로 사용

 

 

show lacp  [interface]

show lacp bundle-ether : LACP 포트 및 해당 피어에 대한 자세한 정보를 표시

show lacp counters : LACP 통계 표시

show int bundle-ether [ ]
show bundle bundle-ether  [ ]

 

clear lacp counters

든 번들의 모든 구성원, 특정 번들의 모든 구성원 또는 특정 포트에 대한 LACP(Link Aggregation Control Protocol) 카운터를 지우려면 EXEC 모드에서 clear lacp counters 명령을 입력

clear lacp counters bundle Bundle-Ether bundle-id | Bundle-POS bundle-id } | port GigabitEthernet interface-path-id | TenGigE interface-path-id | POS interface-path-id } ]

 

lacp packet-capture

LACP 패킷을 캡처하려면 EXEC 모드에서 lacp packet-capture

LACP 패킷 캡처를 중지하거나 캡처된 LACP 패킷을 지우려면 EXEC 모드에서 lacp packet-capture <interface> clear | stop

기본값(no parameters)은 라인 카드의 모든 인터페이스에 대해 전역적으로 실행됨.

lacp packet-capture 명령으로 송,수신된 LACP 패킷은 show lacp packet-capture로 확인 할 수 있다. 

lacp packet-capture 명령은 해당 포트 또는 해당 번들에 대해 stop 키워드가 실행될 때까지 LACP 패킷 캡처를 계속한다.

캡처된 패킷은 해당 포트 또는 번들에 대해 clear 키워드가 발행될 때까지 저장되고 계속 표시된다.

LACP 패킷은 한 번에 라인 카드의 한 포트에 대해서만 캡처할 수 있습니다. 포트에서 패킷 캡처를 시작하면 해당 라인 카드의 다른 모든 포트에서 모든 패킷 캡처가 암시적으로 중지되고 지워진다.

 

인터페이스에서 LACP 패킷을 캡처

RP/0/0/CPU0:router# lacp packet-capture gigabitethernet 0/2/0/0 100

인터페이스에서 LACP 패킷을 캡처를 중지

RP/0/0/CPU0:router# lacp packet-capture gigabitethernet 0/2/0/0 stop

인터페이스에서 캡처된 모든 LACP 패킷을 지우기

RP/0/0/CPU0:router# lacp packet-capture gigabitethernet 0/2/0/0 clear

 

lacp period short

lacp period short receive interval ] transmit interval ]

LACP 패킷을 수신하기 위한 시간 간격(ms). 범위는 100~1000이며 100, 200, 300 등과 같이 100의 배수여야 함 (default 1000)

lacp period short 설정 시 장비 간 transmit 구성 후 receive를 구성한다. (경로 플래핑 발생 방지(경로가 지속적으로 위아래로 이동)

lacp period short 제거 시 역순으로 receive 먼저 제거 후 transmit를 제거한다.

 

RP/0/0/CPU0:router# config 
RP/0/0/CPU0:router(config)# interface gigabitethernet 0/1/0/0 
RP/0/0/CPU0:router(config-if)# lacp period short
RP/0/0/CPU0:router(config-if)# 
RP/0/0/CPU0:router(config-if)# interface gigabitethernet 0/1/0/0 
RP/0/0/CPU0:router(config-if)# lacp period short transmit 500 
RP/0/0/CPU0:router(config-if)# 
RP/0/0/CPU0:router(config-if)# interface gigabitethernet 0/1/0/0 
RP/0/0/CPU0:router(config-if)# lacp period short transmit 500 
RP/0/0/CPU0:router(config-if)# commit
RP/0/0/CPU0:router# config 
RP/0/0/CPU0:router(config)# interface gigabitethernet 0/1/0/0 
RP/0/0/CPU0:router(config-if)# lacp period short 
RP/0/0/CPU0:router(config-if)# 
RP/0/0/CPU0:router(config)# interface gigabitethernet 0/1/0/0 
RP/0/0/CPU0:router(config-if)# lacp period short receive 500
RP/0/0/CPU0:router(config-if)# 
RP/0/0/CPU0:router(config)# interface gigabitethernet 0/1/0/0 
RP/0/0/CPU0:router(config-if)# lacp period short receive 500 
RP/0/0/CPU0:router(config-if)# commit

show lacp io

show lacp packet-capture

lacp packet-capture

'네트워크 > LAG' 카테고리의 다른 글

LAG - configuration  (0) 2023.04.29
LAG(LACP) - 개념  (0) 2023.04.29

+ Recent posts